Форум по программированию Delphi Sources

 



Вернуться   Форум по программированию Delphi Sources > Все о Delphi > Технологии
Ник
Пароль
Регистрация <<         Правила форума         >> FAQ Пользователи Календарь Поиск Сообщения за сегодня Все разделы прочитаны

Ответ
 
Опции темы Поиск в этой теме Опции просмотра
  #1  
Старый 29.05.2007, 13:31
root root вне форума
Прохожий
 
Регистрация: 29.05.2007
Сообщения: 1
Репутация: 10
По умолчанию Ошибка при подключении dll написанной на delphi к веб-сервису asp.net

При выполнении данного кода выскакивает исключение EOleSysError.
Может мы подключаем dll неправильно, а может в dll что то не так(отдельно dll подключали в delphi и тестили - все работает)

код в dll
library ole;
uses
SysUtils,
ComObj,
OleCtrls,
ActiveX;
{$R *.res}
function GetPoint(xy: Integer): integer; stdcall;
var
...
begin
....
try
CoInitialize(nil);
except
result:=-5; exit; end;

try
Appl:=GetActiveOleObject('AMap3.Application');
except
on EOleCtrlError do
begin result:=- 61; exit; end;
on EOleException do
begin result:=-63; exit; end;
on EOleRegistrationError do
begin result:=-64; exit; end;
on EOleSysError do
begin result:=-65; exit; end;
on EOleError do
begin result:=-62; exit; end;
....
try
CoUnInitialize;
except result:=-23; exit; end;
end;

exports
GetPoint;

begin
end.


код в веб-сервисе
...
public class MapPoint
{
[DllImport("C:/Inetpub/wwwroot/WebSite_L-ju/App_Data/ole.dll")]
public static extern int GetPoint(int xy);
}
...
int x = MapPoint.GetPoint(1);
...
спасибо
Ответить с цитированием
Ответ



Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск
Опции просмотра

Ваши права в разделе
Вы не можете создавать темы
Вы не можете отвечать на сообщения
Вы не можете прикреплять файлы
Вы не можете редактировать сообщения

BB-коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.
Быстрый переход


Часовой пояс GMT +3, время: 04:12.


 

Сайт

Форум

FAQ

RSS лента

Прочее

 

Copyright © Форум "Delphi Sources", 2004-2019

ВКонтакте   Facebook   Twitter